Supported devices for Salesforce Mobile

from your device

iOS   |   BlackBerry   |   Android

 

iOS

REQUIRED OS:

Salesforce Mobile supports iOS versions 4.x and 5.x.

SUPPORTED DEVICES:

  • iPhone 4S
  • iPhone 4
  • iPhone 3GS
  • iPhone 3G
  • iPhone
  • iPod touch
     
  • iPad 2 - with iPhone application in compatibility mode
  • iPad - with iPhone application in compatibility mode

HOW TO INSTALL SALESFORCE MOBILE:

To download the application, click on App Store on the device and search for "Salesforce" or visit http:/itunes.com/app/SalesforceMobile from your computer or iPhone.

Back to top

 

BlackBerry

The device must be on the supported devices list AND be running a supported Operating System version. The required minimum memory is not specified because it depends heavily on the mobile deployment (as well as the volume of email and other apps running on the device). At least 128 MB of on board memory is recommended, excluding SD/Media card memory..

As a disclaimer, Salesforce does not test the application on all the devices on all the carriers in the world. If a device is considered as supported based on the requirements below and there is some compatibility problem, we will investigate the problem and resolve it as soon as possible.

REQUIRED OS:

The BlackBerry Operating Systems supported include versions 4.3, 4.5, 4.6, 4.7, 5.0, 6.0, and 7.0. The version 4.2 is NO LONGER supported. However, users will be able to download an older version of Salesforce for BlackBerry. Please note, all of the supported devices listed below can be upgraded to v4.5 or higher.

SUPPORTED DEVICES:

  • Series 81xx (Pearl)
  • Series 83xx (Curve)
  • Series 85xx (Curve)
  • Series 88xx
  • Series 8900 (Javelin)
  • Series 90xx (Bold)
  • Series 93xx (Curve)
  • Series 95xx (Storm) *
  • Series 96xx (Tour)
  • Series 97xx (Bold)
  • Series 98xx (Torch)*
  • Series 99xx (Bold)

DEVICES PHASED OUT:

  • Series 71xx
  • Series 72xx
  • Series 75xx
  • Series 87xx

The support for these models have been deprecated because of the low memory available for applications. Although not supported, some customers run Salesforce successfully on these devices.

CARRIERS / COUNTRIES:

For proper access to the Mobile Server, the device needs either:

  • MDS (BlackBerry Mobile Data Service), OR
  • BIS (BlackBerry Internet Service)

Any Carrier is considered supported if the customer has a BES (BlackBerry Enterprise Server) and intends to use the MDS (BlackBerry Mobile Data Service) connection.

Otherwise, the chosen Carrier must provide a BIS (BlackBerry Internet Service) connection. it is necessary to verify if the Carrier in a specific Nation offers BIS. Research In Motion (RIM) and/or the Carrier are the only official sources for this information.

IMPORTANT NOTES:

  • Salesforce CRM Mobile for BlackBerry does not support 100% of the features offered in salesforce.com's desktop based application, and supported features may vary depending on device type and Mobile operating system.
  • * Series 95xx (Storm) and Series 98xx (Torch) utilize the exact same Salesforce CRM Mobile software as other BlackBerry devices. As such, some aspects of Salesforce CRM Mobile are not optimized for the touch interface.

Back to top

 

Android

NOTE:

This product is currently in BETA. The edit feature is currently not implemented. Bugs will not necessarily be addressed in a prompt manner.

REQUIRED OS:

Salesforce Mobile requires Android OS 2.2 or 2.3 on the device. Other operating system versions are currently not supported.

HOW TO INSTALL SALESFORCE MOBILE:

To download the application, click on Market on the device and search for "Salesforce" or visit http://m.salesforce.com from your Android device.

Back to top